3.25.1 InteleShare Release Information

Scheduled for Apr 23, 22:00 EDT  -  Apr 24, 00:00 EDT

Update

InteleShare (Ambra) v3.25.1.0 Release Dates in April

EU, APAC: April 2nd
Private Cloud: April 3rd
US Release: April 23rd

Release Notes:
https://serviceportal.intelerad.com/csm?id=kb_article_view&sysparm_article=KB0032706

If you have any questions, please connect with our team via the Service Portal (serviceportal.intelerad.com).
Posted Mar 21, 2025 - 21:16 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 21, 2025 - 18:42 EDT

Scheduled

InteleShare (Ambra) v3.25.1.0 Release Dates

EU, APAC: April 2nd
Private Cloud: April 3rd
US Release: April 23rd

Release Notes:
https://serviceportal.intelerad.com/csm?id=kb_article_view&sysparm_article=KB0032706

If you have any questions, please connect with our team via the Service Portal (serviceportal.intelerad.com).
Posted Mar 21, 2025 - 18:40 EDT
This scheduled maintenance affects: Web Services.