InteleShare Incident

Incident Report for InteleShare

Resolved

The incident has been resolved and service is back to normal levels. Our team will be conducting a root cause analysis and sharing as soon as possible. We will continue to monitor the situation to ensure there are no further issues.
Posted Mar 21, 2025 - 11:29 EDT

Update

Our Engineering teams are continuing to investigate this issue, however we are now seeing overall performance improvement. We will continue our investigation of this issue and provide further updates as received.
Posted Mar 21, 2025 - 11:02 EDT

Investigating

We have received reports of issues on the InteleShare platform. Engineering teams are currently investigating. Additional information will be provided as soon as it is available.
Posted Mar 21, 2025 - 10:35 EDT
This incident affected: Web Services, Image Processing, and Image Viewing.