The incident has been resolved and service is back to normal levels. Our team will be conducting a root cause analysis and sharing as soon as possible. We will continue to monitor the situation to ensure there are no further issues.
Posted Jan 14, 2025 - 13:55 EST
Monitoring
At this time, the services backlog has improved and studies should now be ingesting, however we continue to monitor the situation to ensure this progress continues as expected.
Posted Jan 14, 2025 - 13:31 EST
Investigating
Our Engineering teams continue to investigate and work to identify a resolution. We understand the urgency and we appreciate your patience as we work to address the issue.
Posted Jan 14, 2025 - 12:48 EST
Identified
Our engineering team has identified a services queue backlog that has affected the ingestion of studies to InteleShare. Studies are now ingesting, but it may take time to catch up on the backlog. The engineering team continues to investigate the issue and we will provide further updates as they are available.
Posted Jan 14, 2025 - 12:23 EST
Investigating
We have received reports of issues on the InteleShare platform. Engineering teams are currently investigating. Additional information will be provided as soon as it is available.
Posted Jan 14, 2025 - 12:05 EST
This incident affected: Web Services, Image Processing, and Image Viewing.